Youtuber Press Youtube APIテストができません。『動画が取得できませんでした。条件を見直して下さい。』 | ワードプレス魔改造屋

Youtuber Press Youtube APIテストができません。『動画が取得できませんでした。条件を見直して下さい。』

【その疑問や悩みについてネット検索で調査済みですか?】

はい

【その疑問や悩みはマニュアルには載っていないことですか?】

はい

【阿修羅ワークスのプラグインは全て最新ですか?】

はい

【結果として今どうなっていますか?】

マニュアル通りに進め、Youtube APIテストをおこなっているのですが、
Youtube APIテストがうまくいきません。

『動画が取得できませんでした。条件を見直して下さい。』と表示されてしまいます。

GoogleCloudPlatformも特に何かしたわけではなく、どのように解決すればよいのかわからず困っております。

宜しくお願い致します。

【何をしたらそうなったか直前の操作や変更箇所について教えて下さい。】

マニュアル通り進めております。
Youtube APIキーを入力したぐらいです。

【以前はどのような状態でしたか?】

今回が初回です。

【どのような状態になればいいと考えていますか?】

Youtube APIテストができるようになればと思います。

コメント

  1. 2021/03/04(木) 13:56:23
    Youtube APIテストができない件ですが、おそらく使用量のQuotaが足りない可能性があります。
    ※足りている場合はGoogle Cloud PlatformのYoutube Data API v3の設定が間違っている可能性があります。

    さきほどプラグインをバージョン「1.5.5」にアップデートしたので一回アップデートして下さい。
    バージョン「1.5.5」では、テスト結果のより詳しいエラー内容が表示されるようになっています。

    まずエラー内容を特定する必要があるので、バージョンアップ後に再度Youtube APIテストを試して、エラー内容をコピーしてご連絡下さい。
    よろしくお願い致します。
  2. 2021/03/04(木) 14:26:20
    ご確認ありがとうございます。
    Google Cloud Platformの確認もしてみます。

    またバージョンアップを行い、再度Youtube APIテストを行いました。
    エラー内容はどこに表示されますでしょうか。

    • 2021/03/04(木) 14:35:06
      > エラー内容はどこに表示されますでしょうか。

      画面上部の「Youtube APIテスト」というタイトルの下です。
      次回よりスクリーンショットを撮ってアップロードをお願い致します。
  3. 2021/03/04(木) 15:16:45
    ありがとうございます。
    現在の状態を再度スクリーンショットしました。
    特に変わりない感じとなります。
    • 2021/03/04(木) 17:32:37
      なるほど。ということはQuota絡みではなさそうですね。
      エラーの生ログが見れるように改修したバージョン「1.5.5.1」にアップデートしてリトライしてみて下さい。
      今度は細かいエラーが表示されるはずです。
  4. 2021/03/04(木) 18:18:52
    ご連絡ありがとうございます。
    バージョンアップを行い、エラーが表示されました。
    添付いたします。

    ご確認お願い致します。
    • 2021/03/04(木) 18:45:37
      エラーが「Request contains an invaild argument.」となっていますね。
      これは設定に問題がある場合に表示されます。
      Youtube APIテストを行う前に [ Youtuber Press ] → [ 設定 ] → [ Youtube API設定 ] タブの設定をしていたでしょうか?
      もしそうであれば、一旦 [ Youtuber Press ] → [ 初期化 ] を実行してリセットしてから「Youtube APIテスト」を行ってみて下さい。
      メッセージに変化があるかどうか確認して下さい。

      また、こちらでもご使用のAPIキーをテストしてみるので、返信フォームのプライベートフォームにAPIキーを入力して送信して下さい。
      このプライベートフォームは私以外には見られなくなっています。
  5. 2021/03/04(木) 18:50:59
    > [ Youtuber Press ] → [ 初期化 ] を実行してリセットしてから「Youtube APIテスト」を行ってみて下さい。

    こちらを行ったら表示されました。
    ありがとうございます。

    先に設定を触っていたかもしれません。
    ご対応いただきありがとうございました。
    • 2021/03/04(木) 18:54:02
      表示されたということで良かったです!
  6. 2021/03/04(木) 23:08:57
    再度確認をお願いしたいため、プライベートフォームにて詳細記載させていただきます。
    • 2021/03/05(金) 01:37:25
      添付されたZIPファイルですが、安全性が担保できないためダウンロードができません。
      お手数ですが画像ファイルとして別々にアップロードをお願い致します。
    • 2021/03/05(金) 02:36:56
      原因が分かりました。Youtube Data API v3の「videoCategoryId」の指定方法が厳密になったのが原因のようでした。
      コードを修正したバージョン 1.6.0 にアップデートして再度お試し下さい。
  7. 2021/03/05(金) 11:21:35
    ご対応ありがとうございます。
    共有させていただいたAPIキーですと添付のエラーが出ており、
    別アカウントのAPIキーでは問題なく表示できました。
    APIキーをやりくりして作業を進めていきたいと思います。
    諸々ありがとうございます。

    念のため、エラーを添付にて共有させていただきます。
    • 2021/03/05(金) 12:25:26
      添付の画像のエラーは一日の使用量を超えた際に出るエラーです。
      使用量制限は0時に回復します。
  8. 2021/03/05(金) 20:52:29
    再度確認をお願いしたいため、プライベートフォームにて詳細記載させていただきます。
    • 2021/03/05(金) 23:24:04
      なるほど。分かりました。
      バージョン 1.6.1にアップデートして再度試してみて下さい。
      おそらくこれで行けると思われます。
  9. 2021/03/06(土) 00:25:13
    ありがとうございます。
    バージョンアップを行い、登録済みのフィードを削除し、初期化、投稿履歴初期化を行いましたが、投稿はされず、今までと同じ挙動となります。

    ・手動フィード取得では添付(youtubeAPI_12.png)が表示されました。

    ※Youtube APIテストでは表示されます。(youtubeAPI_13.png)


    度々申し訳ございません。
    週明けでのご回答で構いませんゆえ、ご確認をお願い致します。
    • 2021/03/06(土) 06:38:59
      私の方はお借りしたAPIキーで「ハワイ」というキーワードで投稿ができています。
      添付ファイルのエラーのログがどうなっているか詳細を見られるようにしたバージョン1.6.2にアップデートして、手動フィード取得してみてください。エラーをご報告下さい。

      また、単純に動画が検索にヒットしないだけ、というパターンもあります。
      実行したフィードのスクリーンショットも一緒に送って下さい。
  10. 2021/03/07(日) 00:07:16
    ご連絡ありがとうございます。

    申し訳ございません。

    バージョン 1.6.1→バージョン 1.6.2へのバージョンアップに関して、何度更新をかけてもバージョンアップされない状態です。
    更新を押すと更新されましたと表示されるのですが、プラグインの更新をチェックを押すと更新されていない状態となります。
    ※youtubeAPI_14.png→youtubeAPI_15.pngを繰り返している状態。

    ご確認をお願いできますでしょうか。
  11. 2021/03/08(月) 10:46:58
    お世話になっております。

    先ほど、更新をしたところバージョン 1.6.2へ移行できました。
    これよりテストし共有いたします。
  12. 2021/03/08(月) 11:02:12
    お世話になっております。
    テストを行いました。エラー内容を添付いたします。

    ・[ 設定 ]→[ Youtube APIキー入力 ]→[ 変更を保存 ]※エラーなし
    ・フィード登録※エラーあり(youtubeAPI_16.png)
    ・手動フィード取得※エラーあり(youtubeAPI_17.png)
    ・Youtube APIテスト※エラーなし(youtubeAPI_18.png)

    お手数でございますが、ご確認のほどよろしくお願い致します。
    • 2021/03/08(月) 13:10:32
      エラー確認しました。
      このエラーについては前バージョンで修正済みとなっています。
      お借りしているYoutube APIキーで試したところ投稿は正常にされていることを確認しています。

      考察ですが、Youtube APIテストが成功して、フィード登録と手動フィード取得で失敗する原因が引数にある場合、違いはチャンネルIDのみです。
      チャンネルIDを設定されているでしょうか? 私はチャンネルIDは設定していません。

      1.もう一度バージョンが最新の1.6.2か確認をしてみる(されていない場合はサーバーキャッシュが原因の可能性あり)
      2.Youtuber Pressの設定を一度リセットして、APIキーのみ入力する
      3.フィード登録は「フィード名」と「キーワード」のみ入力する

      この条件でリトライしてみて下さい。
  13. 2021/03/08(月) 15:03:40
    ご確認ありがとうございます。

    >1.もう一度バージョンが最新の1.6.2か確認をしてみる(されていない場合はサーバーキャッシュが原因の可能性あり)
    >2.Youtuber Pressの設定を一度リセットして、APIキーのみ入力する
    >3.フィード登録は「フィード名」と「キーワード」のみ入力する

    上記対応で無事表示されました。
    度々のご質問ご回答いただきありがとうございます。

記事に戻る

コメントを残す